常见问题
探针安装成功,为什么控制台上仍无监控数据?
正常情况下,当您的应用有请求访问后,约5分钟左右,即可在控制台中查看数据。如果没有数据,可能是以下原因导致的:
-
探针超量
查看方法:在左侧导航栏中依次单击管理>配置>Agent管理>Agent管理中查看探针运行状态。 解决方法:禁用掉暂不关注的应用的探针或者购买探针。
-
没有数据访问
解决方法:多次访问嵌入探针的应用后,稍等1分钟左右再在页面中查看。
-
服务器间的时间或时区不一致
解决方法:更正探针所在服务器的时间,与DC时间一致;若是SaaS用户,需将探针所在服务器时间更新至当前时间。
-
配置错误
解决方法:确认tingyun.properties配置文件中的license_key和collector.addresses配置项的值是否完整或者有多余字符。
-
网络不通
查看方法:查看/path/to/tingyun/logs/tingyun_agent.log
现象如下图所示:
解决方法:检查网络状态,保证端口通信正常。
-
Tomcat没有缓存目录temp,导致探针启动失败
现象:Tomcat加载探针启动后,/path/to/tingyun/logs/目录下未生成tingyun_agent.log。
解决办法:在Tomcat根目录下创建temp目录即可。
安装探针后,应用启动报错怎么办?
- 问题现象1:
日志中报错如下:
Error opening zip file or JAR manifest missing : /home/apache-tomcat-8.0.36/tingyunn/tingyun-agent-java.jar
Error occurred during initialization of VM
agent library failed to init: instrument
原因:
找不到指定路径下的tingyun-agent-java.jar或者tingyun-agent-java.jar文件不完整导致启动失败。
解决方法:
校正探针的绝对路径或查看探针的md5,保证探针解压后的完整性。
- 问题现象2:
日志中报错如下:
Exception in thread "main" java.lang.OutOfMemoryError: GC overhead limit exceeded
Exception in thread "Tingyun Agent Shutdown" java.lang.OutOfMemoryError: GC overhead limit exceeded
原因:
内存不足。
解决方法:
增加内存上限,具体数值需联系技术人 员。
- 问题现象3:
日志中报错如下:
java.lang.VerifyError:null

原因:
直接原因是java/net/URLClassLoader嵌码后,校验失败。根因是客户使用的JDK是OpenJ9所致。
解决方法:
探针配置如下:
class_transformer.classloader_delegation_excludes=java/net/URLClassLoader
安装探针后,没有生成logs目录
现象:Java探针部署完后,执行ps -ef |grep tingyun,已经有tingyun应用进程了,但是tingyun目录下没有生成logs目录。
原因:
可能有以下三种情况:
-
有其他厂商的探针,可以通过
ps -ef |grep agent确认。 如果有,需要在友商目录下执行uninstall命令。直接使用killall命令杀掉友商的进程,是无效的。 -
tingyun目录没有权限,至少需要给755的权限。
chmod -R 755 ./tingyun